Category: Horizon

Sitecore Horizon 9.3 Install, Troubleshooting, and Uninstall

I want to share my experience on the Installation of Sitecore Horizon 9.3, Uninstallation, and the errors I faced during installation.

Prerequisites

  • Install Sitecore 9.3 
  • Ensure CMS site is accessible with https protocol
  • Ensure WebSocket Protocol enabled

After installing the tools, restart your machine.

Installation

  • Download Horizon 9.3 from here. I downloaded the on-premises deployment.
  • Extract the zip file and open Parameters.ps1
  • Fill out the below parameters –
  • Run install.ps1 in Powershell Administrator mode
  •   Once the installation is done (only takes 2 to 3 minutes), you will see a new Icon in Sitecore 
  •   Clicking the Icon opens Horizon (yes, it’s separate IIS site) and you can explore the new features!

Troubleshooting Error

I faced this error after the installation was successful. When I opened Horizon, here is the error message I got.

Failed to render a page: Failed to render the root extension, with error: Failed to render a fragment. Status code: InternalServerError, message:

I checked the logs (C:\inetpub\wwwroot\[Hoirzon Website\logs) and it showed below message

[1] Ensure that Node.js is installed and can be found in one of the PATH directories. Make sure the Node executable is in one of those directories, or update your PATH.

I verified that the Node.js path (C:\Users\manbalagan\AppData\Roaming\nvm\v10.16.0\) was accessible and PATH was correct.

Also, I uninstalled Node v10.16.0 and reinstalled. Restarted my machine. Nothing helped.

Finally, I resolved the issue by adding ‘Everyone‘ permission and allowed full control to NVM folder (C:\Users\manbalagan\AppData\Roaming\nvm) fixed the issue! IIS couldn’t access the folder without ‘Everyone’ permission.

Uninstall

If you want to uninstall the failed versions (to clean up IIS sites it created), here is how you can do it –

  • Uninstalling is straight forward – just need to run the uninstall.ps1 script 
  • After uninstalling, it didn’t remove the Horizon Icon in Desktop mode. Clicking on the icon goes to 404 page.  It would be clean if the icon is also removed.

Hope this helps someone. Any issues, let me know in comments section.

Happy Sitecoring!

0